Fink:Packaging:Gnome

From the Fink Wiki
Jump to: navigation, search


This page relates to the progress of an update that happened a long time ago. The information here is not current with regards to package/version availability or current packaging standards and best-practices.

Goals

  • Version update (preferably highest stable-branch version, okay if higher than that present in the target Gnome 2.x, or even if part of a higher Gnome 2.x)
  • Update deps according to pkg requirements (add versioning as required by each package, not based on what is currently in fink or what is present in the target Gnome 2.x)
  • Switch to gettext3
    • Depends: gettext→libgettext3-shlibs
    • BuildDepends: gettext-dev→libgettext3-dev
    • Add gettext-bin and/or gettext-tools as needed.
    • Add libiconv* deps as needed.
  • Put -ssl variants first in alternative dependencies (gnome-vfs2 and others). We have gnome-vfs2-unified as of 1:2.15.2-1 now, but not required to switch from the variants list (there are compatibility packages).
  • Make sure static libs are built
  • Add ConfigureParams: --disable-dependency-tracking
  • .info and .deb validation
  • Fix scrollkeeper usage (see fink info scrollkeeper)
  • Fix gconf usage (see fink info gconf2)
  • Check with --build-as-nobody
  • Check locale/ (gettext message catalog) usage:
    • Place locale/ files in the package whose binaries use them (or in a package that is a dependent of that package)—remember Replaces field if moving them!
    • Make sure the domain is orthogonal enough for Shlibs orthogonality
  • Deprecate %N if %N-dev and %N-shlibs contain everything
    • Add Depends to %N to make sure other packages' Depends:%N still gets the same results
    • Adjust dependencies on %N to point to %N-dev or %N-shlibs (with versioning as appropriate) depending on what %N used to contain and its former dependencies:
      • Switch glib2 dependency to glib2-shlibs (>= 2.12.0-1)
    • Switch all glib2* dependencies to >= 2.12.0-1 in both 10.3 and 10.4 to avoid bogus >=2.6.6-1111 from 10.4 transition.
    • Switch all orbit2* dependencies to >= 2.14.2-1, which may eliminate propagated popt dependencies.
    • Switch all libbonobo2* dependencies to >= 2.16.0-1, which may eliminate propagated popt dependencies.
    • NB: only do these when releasing new Version so that we don't force arbitrary rebuilding and "high" Revision in 10.3
      • Therefore, upgrade in dependency order starting at the bottom of the tree
  • Make sure GCC field presence/absence is correct
  • Verify whether 10.4 needs a "high" revision (+=1000 due to GCC:4.0 or dependencies on 10.4-specific high revisions of other packages).
  • Check for .pc files moved to share/ (requires adding Depends: pkgconfig (>= 0.20-1))

Packaging Status

  • Fink: Version in Fink unstable, 10.4 (powerpc). Star when checked and upgraded if necessary—please work in order up the dep tree!
  • 2.x: Minimum version for Gnome 2.x.
  • Notes: what's waiting for what or whom
  • color-code: up-to-date needs updating or is broken unknown

Gnome Platform

Package Fink 2.16 Notes
at-spi 1.7.10 1.7.11
atk 1.12.4* 1.12.2
audiofile 0.2.6* 0.2.6
esound 0.2.36* 0.2.36
gail 1.8.11 1.9.2
gconf2 2.14.0 2.14.0
glib 2.12.11* 2.12.3
gnome-mime-data 2.4.3* 2.4.2
gnome-vfs 2.15.2 2.16.0 >= 2.15.3 is busted (ABI breakage: missing symbols)
gnome-vfs-monikers x 2.15.3
gtk+ 2.6.8 2.10.3 gtk+>2.8 requires enabling cairo and perhaps switching to pango-ft219: cascading BDep additons, may have to tune all pango users
gtk-doc 1.6 1.7
intltool 0.35.5* 0.35.0
libart 2.3.19* 2.3.17
libbonobo 2.16.0 2.16.0
libbonoboui 2.14.0 2.16.0
libglade 2.6.0* 2.6.0
libgnome 2.14.1 2.16.0
libgnomecanvas 2.14.0 2.14.0
libgnomeui 2.14.1 2.16.0
libidl 0.8.8* 0.8.7
libxml 2.6.27* 2.6.26
libxslt 1.1.20* 1.1.17
orbit 2.14.7* 2.14.3
pango 1.10.1 1.14.3 might require shifting to ft219 only?
pkgconfig 0.21 ?

Gnome Desktop

Package Fink 2.16 Notes
alacarte x 0.10.0
bug-buddy 2.14.0 2.16.0
control-center 2.12.3 2.16.0 >=2.12.3 requires gtk+>2.8
dasher 3.2.18 4.2.0 4.0.2 compiling fails
deskbar-applet x 2.16.0
eel 2.14.3 2.16.0
eog 2.12.3 2.16.0 >= 2.13.2 would require gtk+2 >= 2.7.1
epiphany 1.6.5 2.16.0 >= 1.8 would require gtk+2 >= 2.8
evince 0.5.2 0.6.0 0.5.3 would require gtk+2 >= 2.8
evolution 1.5.92 2.8.0
evolution-data-server 0.0.97 1.8.0
evolution-exchange x 2.8.0
evolution-webcal x 2.8.0
fast-user-switch-applet x 2.16.0
file-roller 2.9.1 2.16.0 >2.9.1 needs gtk+>=2.8
gal 2.4.3 ?
gcalctool 5.8.19 5.8.24
gconf-editor 2.14.0 2.16.0
gdm 2.8.0.8 2.16.0
gedit 2.12.1 2.16.0 2.14 needs gtk+2>=2.8
ggv 2.12.0 dropped
glade 2.10.1 ? glade2 ends at glade-2.10.x; glade-2.12.x begins what will be glade3: still in beta and would require gtk+2 >= 2.8
gnome-applets 2.6.2 2.16.0 waiting on gnome-panel
gnome-backgrounds 2.16.2* 2.15.92
gnome-common 2.12.0* ?
gnome-desktop 2.14.0 2.16.0 2.14.1 requires gtk+ >= 2.7.0
gnome-doc-utils 0.8.0* 0.8.0
gnome-games 2.12.3 2.15.92 >= 2.13.1 would require gtk+2 >= 2.8
gnome-icon-theme 2.16.0.1* 2.16.0
gnome-keyring 0.4.9 0.6.0
gnome-keyring-manager x 2.16.0
gnome-mag 0.14.0 0.13.1
gnome-media 2.6.2 2.16.1 in exp/dmacks
gnome-menus 2.16.1* 2.16.0
gnome-netstatus 2.6.1 2.12.0 waiting on gnome-panel
gnome-nettool x 2.15.92 doesn't compile well, doesn't know BSDish tools
gnome-panel 2.6.2 2.16.0 gnome-panel>=2.12 needed for modern gnome-menus, >=2.12 requires gtk+>=2.8; gnome-panel>=2.15 needed to be functional
gnome-power-manager x 2.16.0
gnome-screensaver x 2.16.0
gnome-session 2.14.3 2.16.0
gnome-speech 0.4.4 0.4.5
gnome-system-monitor 2.6.0 2.15.92 2.12.2 full of double-free and invalid UTF-8 errors; 2.14 requires gtk+>=2.8
gnome-system-tools x 2.14.0
gnome-terminal 2.12.0 2.16.0 needs gtk+>=2.8
gnome-themes 2.14.2 2.16.0 miga's
gnome-user-docs 2.16.1* 2.16.0
gnome-utils 2.6.2 2.16.0 needs gnome-panel>=2.9.4
gnome-volume-manager x 2.15.0
gnomemeeting 0.98.0 ?
gnopernicus 0.10.9 1.0.3
gok 0.10.2 1.2.0 in exp/dmacks runtime warning about XInputExtension and dumps core (WONTFIX)
gpdf 2.10.0 dropped
gst-plugins-base 0.10.9 0.10.7
gst-plugins-good 0.10.3.1 0.10.3
gstreamer 0.10.9 0.10.8
gthumb 2.6.9 dropped
gtk-engines 2.6.10 2.8.0
gtkhtml 3.10.2 3.12.0
gtksourceview 1.4.2 1.8.0 1.5.4 requires gtk+>=2.8
gucharmap 1.6.0 1.8.0
libgail-gnome 1.1.3 1.1.3
libgnomecups 0.1.6 x Apple's 10.3 cups-dev lies about its version...it's too low to build this pkg; might work on 10.4
libgnomeprint 2.12.1 2.12.1
libgnomeprintui 2.12.1 2.12.1
libgtkhtml 2.6.3 dropped
libgtop 2.14.7* 2.14.2
librsvg 2.9.5 2.16.0 2.10 requires pango1>=1.2
libsoup 2.2.96* 2.2.96
libwnck 2.14.3 2.16.0
libxklavier 2.2 ?
metacity 2.14.5 2.16.0
nautilus 2.14.3 2.16.0
nautilus-cd-burner 2.14.2 2.16.0
nautilus-media 0.8.1 ?
scrollkeeper 0.3.14* 0.3.14
seahorse 0.8.2 x
sound-juicer x 2.16.0
startup-notification 0.8* 0.8
system-tools-backends x 1.4.2
tomboy x 0.4.0
totem dropped
from 10.4
2.16.0 very old version in 10.3 that doesn't build on 10.4
vino x 2.13.5
vte 0.12.2 0.14.0
ximian-connector 1.5.92 ?
yelp 2.14.3 2.16.0
zenity 2.14.3 2.16.0

C++ Bindings

Package Fink 2.16 Notes
gconfmm 2.10.0 2.16.0 RR's
glibmm 2.10.5 2.12.0
gnome-vfsmm 2.14.0 2.16.0
gtkmm 2.6.14 2.10.0 2.8.x probably requires gtk+>=2.8
libglademm 2.6.3 2.6.3
libgnomecanvasmm 2.14.0 2.16.0
libgnomemm 2.14.0 2.16.2
libgnomeuimm 2.14.0 2.16.0
libsigc++ 2.0.17* 2.0.17
libxml++ 2.10.0 2.14.0 RR's

Java Bindings

Package Fink 2.16 Notes
glib-java x 0.3.2
libgconf-java x 2.12.4
libglade-java x 2.12.5
libgnome-java x 2.12.4
libgtk-java x 2.9.2

Perl Bindings

Package Fink 2.16 Notes
extutils-depends 0.205* ? why is this perl-versioned?
extutils-pkgconfig 1.07* ? why is this perl-versioned?
glib-perl 1.144* 1.120
gnome2-perl 1.040 1.040
gnome2-canvas-perl 1.002 1.002
gnome2-gconf-perl x 1.021 in exp/dmacks; can't test b/c gconf2 missing a .schemas file
gnome2-vfs-perl 1.060 1.060
gtk2-perl 1.122 1.120
gtk2-gladexml-perl 1.005 1.005

Python Bindings

Package Fink 2.16 Notes
gnome-menus 2.16.1* 2.16.0
gnome-python2 2.12.4 2.16.0
gnome-python2-desktop x ? needs gnome-panel>=2.10
gnome-python2-extras x ? 2.14.0 in exp/dmacks; waiting for newer gda
libxml2 2.6.27* 2.6.23
libxslt 1.1.20* 1.1.15
pygobject2 2.12.3* 2.12.0
pygtk2 2.6.3 2.10.0 >= 2.8 would require gtk+2 > 2.8
pyorbit2 2.14.2* 2.14.1